Monterey bug?

ToqueToque Posts: 30
So   I updated my  MacBook air to  Monterey.      So when I save or export something and have to type in  the name........   if you press  "d"     is gives you a mac prompt for dictation......... if I press "f" .... in  the top bar menu  "view"  is highlighted.    Its activating the shortcut.....        Ive tried this on all  my other software and it does not do this.     Just   pyxel edit           My go around is if I need to type in a name with a "d'  or a "F".     I  press the   control  key and D or F..... .   This types in  the letter d or f into the  FILE NAME input square like it normally does...... 
If I turn off in apple    system prefences  dictation off.    Then a prompt asking me if I want to activate dictation??.       

Its a odd thing.    I dont see this in any other software.....     


  • Yup, I"m having this exact same issue when trying to use keyboard shortcuts. I've tried changing the keyboard preferences in OSX but it doesn't work. For some reason Pyxel Edit is hellbent on interpreting "E" (which should select the Erase tool) as "function+E" (which brings up the emoji box), and likewise, it interprets "D" (which should select the Draw tool) as "function+D" (which brings up a dialogue box asking if I want to enable dictation).

    This is a real bummer of a glitch. Not being able to use keyboad shortcuts seriously hampers my workflow, and I imagine I'll have to find another pixel editing app if they don't fix this.
  • @Danik sorry to bother you but do you think a fix for this is possible? it more or less cripples the app for those of us who rely on keyboard shortcuts...
  • Same here
  • DanikDanik Posts: 899
    Sorry for only responding now. I had a hectic time at work and didn’t check the forum in a while. I’ll look into this ASAP over the holidays. 
  • Thanks a lot @Danik, much appreciated!
  • DanikDanik Posts: 899
    Just a small update. I have a fix for the issue, just waiting for a renewed code signing cert as it had expired and I need it to sign the build so that it can be run without issues. If you need a working build urgently email me at support@ and I can send you one. You’ll need to jump through some hoops to run it though. 
  • DanikDanik Posts: 899
    edited January 2
    Here is a workaround for the problem in the mean time.

    1. Go to System Settings > Keyboard > Shortcuts > App Shortcuts.
    2. Add new keyboard shortcuts for the problematic commands to override the standard ones. Make sure you enter the exact name of the menu item ("Emoji & Symbols" for example) for the commands so that it gets replaced, and use a key combination you don't use normally.

    I did not have an issue with Dictation so I don't know the exact name to use there, but the following fixed the E and F keys for me:

  • DanikDanik Posts: 899
    This should be resolved in the latest release (0.4.95).
  • ToqueToque Posts: 30
    It does see to be working now.... Thanks

Sign In or Register to comment.