Got this error when trying to launch a file.


I received this error message when i tried to open up a recently saved tileset that i was working on.

Unknown record signature: 0x9e2a83c1

Error: Unknown record signature: 0x9e2a83c1
at deng.fzip::FZip/parseSignature()
at deng.fzip::FZip/parse()
at deng.fzip::FZip/loadBytes()
at Function/<anonymous>()

Any idea why?

Help would be greatly appreciated due to my assignments deadline. (University Student)


  • DanikDanik Posts: 776
    Hi there,

    Sorry about that, I haven't seen that error before. If you try to make a copy of the file, rename the extension to .zip instead of .pyxel, and then unzip it, does that work? If it doesn't work you could check the autosaves folder for a recent save. 

    Could you email me the file, so that I can investigate what the problem could be?
  • CrimsonCrimson Posts: 2
    edited February 2017
    A workaround i've managed to do is import it into pyxel and then redo the tiling via copy paste etc, however there were some tiles that were lost in the process. Also yeah just gimme a bit to figure it out.

    Also putting it into a .zip and then unzipping doesn't work.
  • Crimson, in case you still have the file, did you rename and change the file extension from .pyxel to .zip and then extract the content or did you zip the file and extract it? it sounds like the latter but that may just be the way you've written it. The former is what you should have tried.
Sign In or Register to comment.