Eraser bug

inkBotinkBot Posts: 53
edited July 2014 in Bug reports
I found a problem with the eraser. When working on a canvas larger than 1800~x1050~ the eraser will stop functioning properly outside of that portion of the canvas. It will still erase whatever you draw over, but it will not show it until you let go of the button/stylus. I noticed this on my large sprite animation document I showed in my other thread.

I do not believe it's linked to that specific pyxel file though, since I tried it with a completely fresh file and the same issue showed. I also recorded it:

Comments

  • DanikDanik Posts: 870
    Yes, I can reproduce the problem. Thanks for the report.
  • inkBotinkBot Posts: 53
    edited August 2014
    It seems the problem does not have to do with canvas size because the problem surfaced again just now for me and I was working on a 650x650px canvas, 10x10 tiles that are 65x65px large.

    Since it doesn't seem to be an issue of size I'd regard this as a big issue from now on.

    Using the latest version 0.3.108.

    Addendum: Seems to be a separate issue where resizing the canvas causes a similar issue to the one I first reported because I did the same as last time and tried with a new document with a canvas sized like the one where I noticed the problem, and there was no problem. Restarting Pyxel and loading the document again fixes the issue.

    The eraser problem with a large canvas size is still present. (Don't know if you've tried to fix that yet though).
  • DanikDanik Posts: 870
    Thanks, I haven't had time to look into the issue yet, but I hope to do so before the next release.
Sign In or Register to comment.