Error #1009

I've been using pyxel for over two years since I bought it, suddenly for no reason, every time I try to import an image (by dragging or using the menu) this error comes up. What to do?

Version 0.4.9 
TypeError, Error #1009

TypeError: Error #1009
at pyx.view.dialogs::SimpleErrorDialog()
at pyx.util::Util$/defaultErrorHandler()
at Function/<anonymous>()

Platform: Windows 10
64 bit: true
Player: Desktop
Version: WIN 33,1,1,217
Screen size: 1920x1080
Window size: 1936x1056
Private memory: 78.309 mb
Total memory: 33.074 mb
Time since start: 17.04s

Num documents: 0

  "documents": {}


  • DanikDanik Posts: 899
    Hi Weylon, sorry to hear that :/
    Does it happen for all image files/formats?
    You can try using Help > Open storage folder, and renaming the Settings folder to something else, in case some persistent setting causes it to happen. If this works it would be very useful to me if you can zip up the failing Settings folder and email it to me so that I can debug to find the issue.

  • DanikDanik Posts: 899
    Actually there is an issue in the error message dialog. If one tries to import a corrupt PNG, GIF or JPG image file they get the error you saw instead of a more descriptive error showing what actually went wrong. Could the files you tried importing have been malformed or are you sure they were valid?
    I have fixed the issue for the next release so the error message should be a lot better.
  • WeylonWeylon Posts: 2
    Hello, sorry for the delay, the problem fixed itself, and I don't know what happened, I haven't changed anything in the program since the day I made this post, it just fixed it, and there were no problems with the images, they were just images, it couldn't be corrupted if ANY other image editor could open, even after the problem corrected itself, it normally imported the same images that gave this error before, what I did was stop using the program for a month or so, since I didn't have it answer until the following month, after about 2-3 months it started working again. I must say it ended up hurting me a bit, but I used alternatives like gimp until a new update comes out.
Sign In or Register to comment.