Catalina,

ToqueToque Posts: 16
A bad bug with Catalina.     I cant save a project.   The save file prompt comes up.   You can select a name and destination but will not save.    You can click on it but does not save.  Have restarted computer and restarted project but still happens.   I can export image before I save so thats good.  But Cant save project...........


Has happened a few times now......  I might have to abandon pixel edit......   I will miss you.  Will try and post a video. 



Comments

  • ToqueToque Posts: 16
    Yeah its just stuck in the the save window.  But I cant save.   Cant cancel or save.    Stuck.  Have to force quit.    


  • ToqueToque Posts: 16
    Confirmed new project.  Multiple attempts...........
  • DanikDanik Posts: 788
    Hi Toque, very sorry to hear that! Did you try saving to different locations? I tried on Catalina and I couldn't reproduce the issue.

    Does it help if you go to the Settings and disable Asynchronous saving at the bottom? You can also try removing the application settings directory /Users/[username]/Library/Application Support/PyxelEdit
  • ToqueToque Posts: 16
    Ok.  Thanks for you suggestions.       I tried  disable asynchronous.    Does the same.    I will try and post a video.         

    Hmm  in finder and terminal I get "no directory exists".     But Im not very technically talented at all......   Is there a file I could search for and delete in the search function?

    I purchased Aseprite.     I like Pixel edit better.  
  • ToqueToque Posts: 16
    Ok. So I tried a few things and could not get it to work.   Restarted computer etc.  Very strange.      BUT   there was a larger  Catalina update so I went through that process this morning.      Now 10.15.2 (19C57).

    Just tried it and it does now indeed save!!!!!!  So happy.     If the problem happens again I will report.   

    thanks so much for you response.     I prefer pyxel Edit!!!!!!!  
  • DanikDanik Posts: 788
    I'm glad to hear you got it working! :)
  • ToqueToque Posts: 16
    Sorry it happened again today.  But not every time I save unlike before when I couldn't save at all.  I thought maybe a corrupted folder so tried a new folder.   I will try some experimenting.   

    It comes up with a save screen.    Click "save"   Then the same save screen comes up but its blank.  Click on save again but its frozen.   Have to force quit. 


  • ToqueToque Posts: 16
    edited January 11
    This save screen comes up and you can select, name and save.
    https://www.dropbox.com/s/wvgi7o2tgr0i87h/FIrstSaveScreen.png?dl=0

    But then immediately this screen comes up but its frozen.    Pyxel edit is frozen

    https://www.dropbox.com/s/uvk073ei3sssclg/ComesUpAfterSaveIsSelected.png?dl=0
    Not sure that helps.  
  • DanikDanik Posts: 788
    Strange. :/ Let me know if you figure out under what conditions it happens/doesn't happen so that I can attempt to reproduce it. Does it work randomly or only after restarting the program, or rebooting the computer?
  • ToqueToque Posts: 16
    https://youtu.be/oLTzYQgJLvo

    Sorry I've tried different things to try and isolate why its doing this.  Thought maybe a video might help at least explain it.     I tried changing names,  restarting.....  different folders.... new folders.........

    I can export my work but I lose my layers/  animations.     I will play with it a bit more but I might have to move on.    

    But thanks so much for looking at it and responding.  I do appreciate it.     I would delete and buy again if I knew that would work.    

    I do have to input my key every time and activate it.    But Ive had to do this for a long time so that hasn't changed.  

    Thanks again.  

      




  • DanikDanik Posts: 788
    The video says it's private so I couldn't watch it unfortunately.
    Yeah that doesn't sound like a sustainable way to work. Do you know if the autosaves work?
    I'll try to remember to post back in this thread if I manage to reproduce it and fix it.
  • ToqueToque Posts: 16
    edited February 5
    My apology.  I believe its a public video.    Not sure it will be of much use but you are welcome to have a look at it.   Its a short video. 

                   https://youtu.be/oLTzYQgJLvo             


    No I dont think the autosaves are working either.......
  • DanikDanik Posts: 788
    Thank you for the video. That is a bad issue indeed. Which specific version of Catalina are you running? I don't have the problem on 10.15.1, but I googled around and found some posts where people started having similar issues on 10.15.2.
    https://forums.macrumors.com/threads/macos-catalina-10-15-2-freezes-crashes-mba-every-single-day-am-i-alone.2216672/

    Maybe the first answer here is worth a shot:
    https://community.adobe.com/t5/photoshop/photoshop-2-2020-freezing-while-saving-on-mac-os-catalina/td-p/10776502?page=1

    I will try updating to the latest Catalina version soon to see if that triggers the problem.


  • Hmm I'm facing the same issue, I've tried changing the accessibility settings for PyxelEdit but no luck.. 
  • In terms of reproducible steps, I'm on MacOS Catalina 10.15.3 and I open PyxelEdit and start a new project, then save the project (this seems to work fine). If I then try and save the project again with a different file name the freeze occurs. The freeze also seems to occur if I open an existing project then try to re-save it with a different name. I'm really looking forward to a fix, I don't like Asesprite! Thanks for the awesome software by the way.
  • ToqueToque Posts: 16
    Yeah I tried again today.     10.15.3

    Tried multiple things.    Not able to save.     
    Well at least its not just me.    I wonder as other people update  they will soon have issues........

    The changing of preferences accessibility settings doesn't seem to work.  

    Thanks

  • DanikDanik Posts: 788
    I have updated to 10.15.3 and was able to reproduce the problem. I will try to find a solution as soon as I can.
  • LurkLurk Posts: 1
    I think I might have found something. When saving, I always switch to another folder before going back to the folder I want to save into(in my case, a desktop folder). It seems to nullify the freeze bug. I tried it with a few test files, some with no tiles, some with tiles.
  • ToqueToque Posts: 16
    Yes.   I tried a few times.       If you change the folder it does seem to save now.    But you have to change the folder.   If you save to the same folder it freezes.......

    Tried only   a few times so cant say I extensively tried different things.   
  • WygeWyge Posts: 1
    Hi to everyone!
    Catalina 10.15.3, same issue. Will try the method that Lurk describe, and give a feedback. And wait for bug fix, cause like Pyxel Edit!
Sign In or Register to comment.