Pyxel Edit made my monitor flicker... and now it won't stop.

Racookitty2Racookitty2 Posts: 1
edited April 30 in Bug reports
So, this is a really really strange bug.
I have a second monitor connected to my laptop, where (on the second monitor) I use Pyxel Edit. Keep in mind, my monitor has never flickered! It was fine at first, but then I started to notice that when I zoomed in on the canvas, the edges of the screen started to get increasingly more violent in it's flickering. I thought "Alright, I guess I'll refrain from zooming in a lot". Then after a few days it started getting worse. Every time I opened the program, the screen had a vibrating seizure. And I was disappointed, because I wanted to use Pyxel Edit but now it's impossible to look at because I'm going to get sick. Keep in mind, too, that the flickering literally ONLY happened when Pyxel Edit was open. Recently, I opened Pyxel Edit to see if it fixed itself, and it didn't, so I left the program.
But now it won't STOP. It is very subtle, and I guess I could get used to it but it's there.
I've tried everything... it makes no sense, how could this program cause a permanent visual error? I've tried everything on the internet: changing hertz, changing cables, stopping overclocking...
I guess my question is: Why did this happen in the first place? Can I fix it?

Thank you!

Comments

  • DanikDanik Posts: 764
    That's extremely weird. I can only guess what could have caused it. Maybe the repeating background pattern somehow upsets the monitor, since the zoom level seems to change how much it flickers. If you take a screenshot of the application, and open it on that monitor, does it trigger the issue? Is it an older monitor?
  • BflySamuraiBflySamurai Posts: 1
    edited November 15
    Just wanted to report that I encountered the same error and was able to fix it.
    I was zooming in in Pyxel Edit and then all of a sudden my monitor started flickering and the issue continued outside of Pyxel Edit.
    I ended up fixing the issue by doing the following (I don't know if just uninstalling Pyxel Edit did the trick or whether it was both of these things in combination).
    1. Uninstall and reinstall Pyxel
    2. In System Configuration, under Services, uncheck "Windows Error Reporting" and "Problems Report and Solutions".
    3. Restart computer.
    The entire Pyxel Edit program will still end up flashing under certain circumstances (different combinations of zoom and canvas position), but the issue seems contained to Pyxel Edit now.

    Edit 1: I was working in Pyxel Edit again and the issue resurfaced after just a few minutes. I've tried uninstalling and that didn't fix it. I tried reinstalling and that didn't fix it. I tried re-checking the options in System Configuration, restarting, then unchecking them again and restarting, but that didn't help. Maybe the issue just slowly goes away by itself over time.

    Edit 2: I messed around with Pyxel Edit to see if maybe I could reverse the effects, and I might have gotten things to be slightly better, but the issue that is making my entire screen flicker seems to just be slowly getting better over time.

Sign In or Register to comment.