I have a problem with my Wacom Intuous

machineabusemachineabuse Posts: 3
edited March 2017 in Questions
Hello everyone. I have had this problem for some time now;

In my Wacom Pen settings, I have the lower half of the click set to Right Mouse Button and the top half of the click set to Middle Mouse Button. I only intend to do actual clicks with the pen tip.

In Pyxel Edit, my lower click will only function as the Primary Mouse Button. Is this hard coded or is there a setting I can change somewhere?

The way it is now forces me to transition to my mouse whenever I work with tiles which isn't an ideal workflow for me.

I'd also like to not use the top click as Right Mouse Button to keep my Photoshop interface in parity.

If it is relevant to the discussion, I am using an Intuous 5 Touch with the 6.3.11-4 Driver on Windows 7 Pro. Pyxeledit 0.4.4


  • CandyFaceCandyFace Posts: 620
    Hi machineabuse

    There is no way to modify how those two buttons work as far as I know. Have you tried changing secondary click to something else in the top bar when the Pen tool is selected?
  • machineabusemachineabuse Posts: 3
    edited March 2017
    Hey CandyFace,

    Yeah, that was the first thing I tried. clarify; everything in the UI works correctly on mouse, I only see this discrepancy using right-click on my Wacom Stylus.

    As a matter of fact; right click will not function with either stylus button in Pyxel Edit. When bound to Right Click in Wacom Tablet settings they will perform as if Left Clicking.

    Again, this matters because it means having to transition to mouse whenever needing to sample a tile, which slows things down quite a bit.

    Another curious observation is that while using the stylus, Alt-clicking to sample a color will sometimes result in switching to the color picker instead of reverting to the brush tool.

    Possible driver issue? I would have thought the Wacom would act like a plug and play mouse.
  • CandyFaceCandyFace Posts: 620
    Hmm interesting, i've tested this using my own tablet (Non wacom) and if I change the buttons to act differently, eg. make the bottom one act like right-click, then it acts like the color picker as expected. 

    it does sound like a problem with the Wacom driver, if the button action doesn't change. Does it work if you use a different software?

    I can't reproduce your other issue either, are you sure you're not letting go of the alt key while you are picking a color (holding down your mouse button)?
  • machineabusemachineabuse Posts: 3
    edited March 2017
    I've updated to the latest driver and the problem persisted, however after some fenagling it would appear the problem is caused by Windows Ink. Turning Windows Ink off resolves the issue but of course you lose pressure sensitivity in Photoshop. As I understand, there are workarounds for that so I'll pursue the solution on that end.

    Oh and yes! It seems that releasing alt before bringing up the pen tip is the culprit!

    Thanks for your time CandyFace :)


    Ok, so just in case anyone else has to do this; to get pressure sensitivity back in Photoshop without using Windows Ink you need to create a new PSUserConfig.txt file in your Photoshop settings folder (that varies depending on which build of photoshop you are using.).

    In the file write;
    # Use WinTab
    UseSystemStylus 0
    This will force Photoshop to load up the legacy WinTab libraries that were previously used by Wacom. I don't even get why Wacom doesn't just continue to do so since Windows Ink is buggy as is. Cheers!
Sign In or Register to comment.