White Screen on Launch Fix

BaleBale Posts: 3
edited February 2018 in Bug reports

Finally decided to give PyxelEdit a try. Oops, it launches to a white screen after installing it (Win 7, non-domain-joined). Thisisembarassing.xml. Tried running as admin, installing to root, clearing the %appdata% files, lots of things. What the fuck is this shit. Created a debug.file in the \PyxelEdit\META-INF\AIR folder and launched. Error #2014 exception thrown. Lines of code basically saying AIR can't find the resources it needs. I think to myself, I probably don't have flash player installed on this machine. Installed flash player. Restarted computer. Look at that it works.

TL:DR: Devs, please inform your purchasers/users that you must have Flash Player installed to run this shit, or at least put this in the FAQ. AIR does not compensate as a standalone. This was frustrating. -5 house points.




  • CandyFaceCandyFace Posts: 623
    edited February 2018
    Hi Bale

    It could be a coincidence that it started working after you restarted your computer with Flash because Flash is not required to get PyxelEdit working. The only thing you need to install is Adobe AIR   which relies on some of the same tech, ie. actionscript but it does not require flash to be installed. Everything should be bundled with the application now, older builds did require AIR to be installed but that's not the case anymore as Danik says.
  • DanikDanik Posts: 899
    Sorry about that. You do not need to install Adobe Flash or Adobe AIR to run the application, the runtime is bundled in the download. I haven't seen that error before, I agree that it's very unhelpful.

    I did some research. Do you have your "Documents" folder pointing to a network location? It could be that the application can't access it. If you right click the Documents folder, choose Properties, then go the the Location tab, what's the path there? I'll check if I can catch the error and show something more informative. If you could share the stacktrace for the exception that would help a lot. 
  • BaleBale Posts: 3
    Hey there,

    I thought I copied the log to a txt, but I can't find it. Sorry about that. I will tell you this, my documents folder is pointed to the right location. No network drives mounted. Additionally, I had tried restarting the machine twice before installing Flash and restarting. 

    I may be able to point you in a direction. Before installing Flash, the folders %appdata%\Pyxeledit\ELS and "%appdata%\Pyxeledit\Local Store" were not being created on launch of PyxelEdit.exe. After installing Flash, these folders were correctly created with a successful launch of PyxelEdit.exe. Seems like a dependency issue that something in the Flash package is providing.

    Best of luck,

Sign In or Register to comment.