Updated Adobe Air and Pyxel Edit will no longer open

The new version of Adobe Air just came out and it's now reached the 2.0 revision.

I had Pyxel Edit open and working perfectly and it prompted me to update adobe air. After I did, when I click on Pyxel Edit it bounces once on the dock and that's it. The program won't open and I can't figure out what the problem is.. I tried restarting and that did not help. I wanted to downgrade my adobe air back so I could get back to work but I don't think I can do that.


  • CandyFaceCandyFace Posts: 620
    edited December 2015
    Hi AnAlchemistReborn

    That sounds unfortunate, hopefully though you should be able to uninstall the current version you have and install an older one. Before uninstalling though, have you tried removing the config for Pyxel Edit? The config might have been corrupted, I don't know why it should though...

    Should that not work, then you could try reinstalling to an older version. I've been using 1.5 since forever myself, so that version should at least work. You can get the older version of Air via this:
  • How exactly do I remove the config? I am using a mac so the process might be a bit different. I tried installing the old version of Air you linked and it did not help :(
  • CandyFaceCandyFace Posts: 620
    edited December 2015
    Ahh sorry to hear, i assumed you were using windows as you didn't mention it. You can remove config on OSX by going to this location and remove the folder.

    /Users/YourName/Library/"Application Support"/PyxelEdit/

    also did you first remove the old version of Adobe Air? you should be able to remove it by using this command in terminal:
    sudo /Applications/Utilities/Adobe\ AIR\ Uninstaller.app/Contents/MacOS/Adobe\ AIR\ Installer -uninstall

    I have also found a better link you could try. 
    Select an older version for Mac after having uninstalled your current version and see if it works :)
    Be sure to download the runtime and not the SDK.
  • Uninstalled using the terminal command as you suggested then reinstalled version 19.0.0 from the link you supplied. Pyxel Edit booted up no problem after this, thanks so much CandyFace!

    As for the new version of Adobe Air, it is defiantly the source of the problem. Either don't update or the issue needs to be patched.
  • I suspect this may be the problem I had when I installed just now. I let the PyxelEdit installer install Air for me, and I believe it was version 20. I was able to work around it without downgrading Air:

Sign In or Register to comment.