Gray Screen on startup

So I just got pyxel edit and immediately after downloading it when I tried to launch it the program opens as nothing more than a gray screen with no additional features. If I could get any information on how to fix this issue that would be appreciated, also I'm bad with computers so the more descriptive the response the better 

Comments

  • CandyFaceCandyFace Posts: 565
    Hi Royceope 

    You should try the following:
    Delete the application storage directory to fully reset the application in case some settings got corrupted, you can find this folder on windows and mac here:

    Windows: C:\Users\[username]\AppData\Roaming\PyxelEdit or similar.
    You can enter %appdata% as the path in windows explorer to find the Roaming folder quickly.

    Mac: /Users/[username]/Library/Application Support/PyxelEdit or similar.

    Make sure you have updated to the latest version of Adobe AIR.
  • Royceope Posts: 5
    I have done both the following and unfortunately have experienced no change 
  • CandyFaceCandyFace Posts: 565
    Sorry to hear it doesn't work. If you open the PyxelEdit folder in Appdata, what folder and files are available? do you by any chance have a log file in /Local Store/Logs/ ? also have you tried restarting your computer? 
  • Royceope Posts: 5
    I only see a #air version folder in that location and I restarted my computer after the initial problem but not since applying the changes you suggested. Would /Local Store/Logs/ be within the PyxelEdit folder within appdata typically? if not where else should I be looking
  • CandyFaceCandyFace Posts: 565
    Yes the log file should be located in there. Since no files or folders have been generated beside the #air folder though, maybe it's a permission problem. Have you tried to run PyxelEdit as administrator? Usually even if you get gray screen on startup, you should still have a Local Store folder and a config file
  • Royceope Posts: 5
    I have attempted to run it as an administrator with the same results as before. Is it possible for me to create those folders or is there anywhere else they could have ended up?
     
  • CandyFaceCandyFace Posts: 565
    edited February 1
    Hmm well you could create the folder manually but I doubt it's going to change anything. No they shouldn't be able to end up anywhere else.

    Try to uninstall adobe air completely, then restart your computer and install the latest version again.
    Remove the runtime on a Windows computer
    In the Windows Start menu, select Settings > Control Panel. 
    Open the Programs, Programs and Features, or Add or Remove Programs control panel (depending on which version of Windows you are running). 
    Select “Adobe AIR” to remove the runtime. 
    Click the Change/Remove button.

    Also, have you by any chance tried any of the earlier versions of AIR and PyxelEdit?

  • Royceope Posts: 5
    that didn't work either. I have tried versions 4.1 and 4.2 of PyxelEdit as well with the same results, I have not tried other versions of AIR though.
  • CandyFaceCandyFace Posts: 565
    edited February 2
    Do you have Anti-virus software installed on your computer or maybe a firewall enabled? If that's the case, try to disable those temporarily and start PyxelEdit again. 

    If not, you may have to contact Danik via support@pyxeledit.com. Explain him the situation and the things you've tried and he'll probably provide you a debugging build that enables some functionalities that makes it clearer for him to see what's going on. 
  • Reynir Posts: 1
    I had the same problem and found no solution so I'll share how I got things working.

    I enabled debug by putting a "debug" file in \PyxelEdit\META-INF\AIR and got an error msg when starting Pyxel that started with (incomplete since I didn't copy the whole thing at the time):

    Error #2014: Feature is not available at this time.
    ...and something about not finding the Documents directory (or at least one of the windows library folders).

    What I did:

    !!! I Don't know the consequences of doing this if you're relying on these libraries in some way  !!!

    I changed all libraries back to their default values through regedit.
    For example the data for the Documents library is at (these are the default values I changed to, similar for other libraries):

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
    Personal=C:\Users\Administrators\Documents

    and

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    Personal=%USERPROFILE%\Documents

    After restoring to defaults I rebooted and could open Pyxel Edit.
Sign In or Register to comment.