Annoying Issue: Having to input Activation Key every time I launch Pyxel.

Took a break from using Pyxel for a while, and recently updated the latest 4.3 version,

Although not a major issue of course as it's as simple as a copy/paste, it's a little frustrating having to bother with this every time I launch pyxel.  I've ran the program as administrator and it still does this,  any ideas how to fix this, or is it an intended design choice?

Comments

  • TeirdalinTeirdalin Posts: 8
    edited October 2016
    Even went about completely removing all references to pyxel in the registry and reinstalling the program, and using take ownership on the folder, and running both as admin and as not admin; and it's still asking for my activation code every time I start it; and quite frankly I don't like having to keep a text file of one of my programs activation codes constantly on my desktop. lol
  • CandyFaceCandyFace Posts: 620
    Hi Teirdalin

    Have you tried to remove the PyxelEdit config folder located here:
    Windows: C:\Users\[username]\AppData\Roaming\PyxelEdit or similar.
    You can enter %appdata% as the path in windows explorer to find the Roaming folder quickly.

    Mac: /Users/[username]/Library/Application Support/PyxelEdit or similar.

    It sounds like a typical problem of the program not having access to write to a certain folder and therefore keeps asking for the activation code, but since you've tried most things I would suggest... I'm not sure what else to suggest.
  • DanikDanik Posts: 870
    It does sound like a write permission problem. As a workaround, you can paste your activation key in the file LicenseKey.txt in PyxelEdit/Settings/. The program will check that file on startup.
  • Regenerating the roaming Pyxel folder fixed the problem, thanks a ton Candy and Danik;  also created a licensekey text just incase.
Sign In or Register to comment.