Pyxel won't open whatsoever.

ttokboyttokboy Posts: 2
edited August 2016 in Bug reports
Hey everyone!

Anytime I try to open Pyxel, it just floats in the dock, then disappears. 
I've rolled-back my Adobe Air version, and I'm on OSX El Capitan 10.11.5.
What else should I do?

Thanks!

Comments

  • CandyFaceCandyFace Posts: 620
    edited August 2016
    Hi ttokboy, try to remove the folder located here, this will reset the application settings, in case they have become corrupted:

            Mac: /Users/[username]/Library/Application Support/PyxelEdit or similar.
  • DanikDanik Posts: 870
    edited August 2016
    In case CandyFace's suggestion doesn't work, did you get a prompt to allow or decline keychain access the first time? It stores the license info there so it needs access it. I'm not a Mac user so I don't know the exact steps, but you should be able to give it permission in the Keychain Access app.
  • ttokboyttokboy Posts: 2
    Hey guys!

    I tried both of your suggestions, but Pyxel still doesn't want to open. I think it might be a problem with the version, because 0.3.109PR3 works fine. I'm not sure what else I could do, so I might have to stick with 0.3.109 until the next update comes out.
  • DanikDanik Posts: 870
    That's odd. You could check the log file in /Users/[username]/Library/Application Support/PyxelEdit/pyxeleditlog.txt (if it exists) to see if it gives any hints on the problem.
  • Hi everybody! I just bought Pyxeledit as well, but it simply doesn't boot for me.. I'm on MacOS 10.11.6 and uninstalled the Adobe Air I had on the laptop already. Is there maybe a place where I can download an older version that did work on Macs?

    Thanks in advance!
  • CandyFaceCandyFace Posts: 620
    edited August 2016
    Hi RadicalRaid

    Have you already tried what was suggested above? if not try that first. The version of AIR you had installed already shouldn't conflict with the one built-in into PyxelEdit.

    On the page where you downloaded the latest version, you can also see older versions below, just pick one. These versions do require an stalled copy of AIR though.
  • Hi CandyFace, I did try that, but the folders weren't there. Probably meaning the App didn't start at all.. I'll have a look and try out an older version!
    Any other advice would be very welcome too.

    The latest version works fine on Windows by the way, I just like working on my Mac more.
  • CandyFaceCandyFace Posts: 620
    What happens if you right-click on the application and chose "Open" ?
  • I see Finder switch focus to another window and immediately switch back. No application is booted though. However! Version 0.3.109PR4 is working for me, so I'm using that for now on my laptop. But if you have any tips I'd love to hear them!
  • CandyFaceCandyFace Posts: 620
    edited August 2016
    I would like you both to try some things:

    Right-click on the 0.4.0 application, choose "show package content", open Contents/MacOS and click on PyxelEdit. Did anything happpen?
    At the same time open Console.app, and use the top right bar displaying "search" type Pyxeledit and insert the log here.

    Since you have the older version working, you should have a PyxelEdit or PyxelEditPR folder located in the Library/Application Support folder now. However, if you're unfamiliar with the OSX environment, the Library folder will be hidden, you therefore have to either use terminal.app, and write "Open /Users/[username]/Library/Application Support/PyxelEdit/" or open Finder app, go to the top bar, click on the "Go" tab, hold down alt/super and the library folder will reveal itself.

    If you do have a "PyxelEdit" folder now, try to delete it and open the application again. You'll have to insert your key again.
  • DanikDanik Posts: 870
    A new update is now out, please try it out and see if the problem persists. If it does, could you check the log files in /Users/[user]/Library/Application Support/PyxelEdit/Local Store/Logs/ and paste them here or send them to me at danik@pyxeledit.com? That should let me know if any errors happen on startup.
  • The latest versions works for me! Thanks :)!
Sign In or Register to comment.