Wacom Pen Lag Problem?

Hello! I'm relatively new to using PYXEL, but I seem to be having a bit of a problem if anyone can help me?

I'm experiencing a little lag at the beginning of my brush strokes when I'm trying to draw in the program (I use an Intuos Pro tablet).
I've checked in my Pen and Touch settings and both flicks and the press and hold function are turned off, yet I still seem to be having this problem.

Is there something I'm missing or something I can do to make my brush work smoothly?
Thank you!

Comments

  • CandyFaceCandyFace Posts: 620
    edited June 2016
    Hi alipeanut

    PyxelEdit does not support tablet pressure sensitivity currently, so the lag you might experience may be because it requires a certain amount of pressure for the tablet to actually draw. This is just my assumption though, as I have a tablet myself but haven't experienced such issues.

    it could also be, that you have "clean 1 pixel line" active, which means that your brush will avoid drawing at certain angles to keep the line clean.

    If you're still having problem, then please try to elaborate on the lag.
  • alipeanutalipeanut Posts: 3
    Hello CandyFace!

    Ah okay, that might be the cause. I'm unsure of how to change or turn off the pressure sensitivity overall for my tablet, and am unsure if it's even possible.

    I did attempt turning the 'clean 1 pixel line' setting on and off and am still having the same problem. I've attached a photo here to show what's happening;

    image

    My pen seems to have a bit of a hiccup at the beginning of my brush strokes where it won't draw in a curve, but rather a straight line, but otherwise it works fine afterwards.

    Thank you for replying to my post!
  • CandyFaceCandyFace Posts: 620
    edited July 2016
    Do you know if this happens in other programs as well? It sounds like a known problem with wacom tablets when windows "pen and touch" is activated. 

    Try to do the following:
    The solution for this is to disable two settings that are on by default in Win7: "Press and Hold" and "Flicks".
    1. Open the Control Panel and type "tablet" into the search field
    2. Select "Pen and Touch" settings
    3. From the "Pen Options" tab, select "Press and Hold" and click "Settings..."
    4. Make sure "Enable press and hold for right-clicking" is unchecked.
    5. Click OK.
    6. Select the "Flicks" tab
    7. Make sure that "Use flicks to perform common actions quickly and easily" is unchecked.
    8. Click Apply, and OK.
  • alipeanutalipeanut Posts: 3
    Yes I have had these settings previously disabled and the problem is still happening :(
    I haven't had this problem in any other program, only Pyxel Edit.
  • CandyFaceCandyFace Posts: 620
    Hmm i'm sorry to hear that, let us try some other things then.
    If you haven't, try to install an earlier version Pyxel Edit. This might be able to narrow the problem down to a specific version, if is a bug.

    If you use a mouse to draw with, do you still experience the lag?
  • シェドシェド Posts: 6
    edited July 2016
    Hi! I have the same problems as alipeanut but I think I know the problem that's causing the lag. The way WACOM works (on mine at least) is when you hold the pen down, it will show a loading circle that will initiate a "right click". So while it's waiting for that loading to finish to see if the user wanted to right click, I guess PyxelEdit fails to recognize it. Here's a video showing it in action.

    (FYI, it's the white circle, not the blue and orange ones, those are from Bandicam.)
    https://vid.me/fHtM

    Unfortunately, I don't know of a way to fix it. Hopefully it can be resolved soon from the program end.
  • CandyFaceCandyFace Posts: 620
    edited July 2016
    Hi シェド

    I see, but that specific issue should be solvable with the steps I wrote in my second reply. I've searched a bit though and it seems that Wacom has made a feature available in their software that should make it possible to disable this, if the method I mentioned should not work. 

    You can read more about the issue here:
    The link applies to Windows 7, but the solution should be similar if not exactly the same on Windows 10.
  • シェドシェド Posts: 6
    Sorry, I did not read your previous reply, I just saw the original problem and thought to add some video to go along with it. Your suggestion does work. But will this be addressed in the future?
    Hi シェド

    I see, but that specific issue should be solvable with the steps I wrote in my second reply. I've searched a bit though and it seems that Wacom has made a feature available in their software that should make it possible to disable this, if the method I mentioned should not work. 

    You can read more about the issue here:
    The link applies to Windows 7, but the solution should be similar if not exactly the same on Windows 10.

  • CandyFaceCandyFace Posts: 620
    The problem is not specific to this software only, it is a known issue with Windows own pen software and Wacoms. This can only be addressed by Wacom. PyxelEdit doesn't support any tablet specifications currently, so there is nothing to be addressed on the developers side.

    The solution I stated earlier is the correct way to address this problem.
  • spazinskispazinski Posts: 1
    Here is the solution that worked for me with my Wacom Tablet. I hope this helps!
    1. Load "Wacom Tablet Properties" from the start menu.
    2. Go to the "mapping" tab
    3. Uncheck "Use Windows Ink"

  • anjinganjing Posts: 1
    The lag comes from windows character input stuff (the little box in the bottom). Just deactivate it in wacom menus.
    I'm using a XP-Pen Deco 01 Drawing Tabblet ( https://www.xp-pen.com ) on Mac OS X with a  MacBook Pro, and I'm not running into any issues. It's responsive, and I can draw from tile to tile normally without an issue, and no lag in tiling mode.
Sign In or Register to comment.