Alt switches to color pick permanently

Phoenix849Phoenix849 Posts: 7
edited May 2016 in Bug reports
Hi, I've been using Pyxel Edit almost for 2 years and recently updated to 0.4.0. The problem is following: when I tap with my Wacom Intuos Small and simultaneously hit Alt it sometimes switches to color pick tool permanently instead of switching back to pen. A little harder to reproduce with mouse+Alt, but the bug exists as well. It seems to occur when there's a split second delay between clicking and hitting Alt. When delay is a little longer it functions as it should, I mean switching back to pen when I release Alt.

I've never encountered this problem before and it seems to not exist on 0.3.108. It actually hinders my progress a lot since I tend to use Alt-picking quickly and often. So I think I'll go back to 0.3.108 for now. Would appreciate if you could look into this and fix it as it's really irritating when working. Thanks.

Comments

  • lachsenlachsen Posts: 1
    Hey there,

    I have exactly the same problem using version 0.4.0  (Windows 7).

    Here the exact steps to reproduce it:
    1. Select Pen Tool
    2. Hold alt
    3. Press and Hold Left Mouse Button or Push Pen
    4. Release alt
    5. Release Left Mouse Button / Pen

    When done in this order it always leads to the picking tool staying selected. It's a small error but it actually breaks my workflow quite a lot, since I very often pick colors and make this mistake quite often.

    Also: just bought the program today. The tile functionality is awesome! I hope this problem will be fixed as well since it seems to be a regression error.

    For the time being, I think I'll switch to 0.3.108 as well.
Sign In or Register to comment.