Gray screen on startup (Surface Pro 4 128GB/ Windows 10 Pro x64)

Hi,

Searching the forums, I found no threads on the same issue so I'm posting this one asking for help.

I just bought Pyxel Edit yesterday and, even though it is possible to make it run flawlessly on my windows 7 desktop computer, I always end up with a gray screen when trying to run either the air installer or the portable version on my Surface Pro 4. I tried everything I thought of : running from different folders (program files, root of the hard drive etc), running as administrator, toying with compatibility modes, lowering the screen resolution, emptying the application storage as suggested in the FAQ, downgrading Air to version 18.

Strangely the free beta version 0.22.2.c has no problem running on the Surface. This device is quite new and does not has anything particular installed compared to my desktop computer, except that the OS is running completely in Japanese (though I doubt that would impact anything, but that's the only thing coming to my mind).

I'm becoming quite desperate with this. Any suggestions on how I could fix this problem ? Did anyone using the same device as me ran in the same problem ?

Comments

  • CandyFaceCandyFace Posts: 620
    edited January 2016
    Hi Nae

    That sounds unfortunate, and it seems you have tried everything i would have suggested you to try. Three questions though: 
    First, when you say emptied the application storage, did you remove the entire pyxeledit folder?
    Second question, have you tried to downgrade to an even earlier version of Air?
    Third and last question, have you restarted your surface pro at any point while trying to solve the problem?
  • NaeNae Posts: 3
    Thanks for your quick answer.

    I removed the entire pyxeledit folder each time
    Just tried to downgrade to Air version 15, no luck.
    I just rebooted and went through the whole thing again, gray screen again.

    I also tried on a Surface Pro 3 on windows 10, the portable installation worked right out of the box so I doubt it is a hardware related problem.

    One thing I also noticed is that PyxelEdit seems to fail to create the conf files properly, the folder PyxelEdit is created in roaming with only two folders: #airversion and ELS, the latter of which is empty. Looking at the installation on my desktop, the PixelEdit folder in Roaming, contains 3 folders : #airversion, ELS, and Local Store with files in each one. I suspect the program fails to write the files properly because of a non ASCII character in the user name of the account I am using (which cause the path to Roaming to also contains it). I will try to change that see to see if it makes it work.
  • NaeNae Posts: 3
    That was it.

    I changed the user folder with a "clean" name (only under case letters) and PyxelEdit began working all of a sudden. The program seems unable to write on path containing non ASCII characters. (though a lot of programs also behave incorrectly when the user folder contains non ASCII characters and I realize there is a whole lot to do before, that might be worth fixing for the dev when finalizing the release build later down the line)
  • CandyFaceCandyFace Posts: 620
    edited January 2016
    Good to hear you got it working Nae!
    Yeah it seems that @Danik will have to put yet another thing on the todo list, though this one is definitely one of the more critical ones imo.
Sign In or Register to comment.