MacOS Catalina, save dialog freeze

ToqueToque Posts: 20
edited May 8 in Bug reports
A bad bug with Catalina.     I cant save a project.   The save file prompt comes up.   You can select a name and destination but will not save.    You can click on it but does not save.  Have restarted computer and restarted project but still happens.   I can export image before I save so thats good.  But Cant save project...........


Has happened a few times now......  I might have to abandon pixel edit......   I will miss you.  Will try and post a video. 



Comments

  • ToqueToque Posts: 20
    Yeah its just stuck in the the save window.  But I cant save.   Cant cancel or save.    Stuck.  Have to force quit.    


  • ToqueToque Posts: 20
    Confirmed new project.  Multiple attempts...........
  • DanikDanik Posts: 800
    Hi Toque, very sorry to hear that! Did you try saving to different locations? I tried on Catalina and I couldn't reproduce the issue.

    Does it help if you go to the Settings and disable Asynchronous saving at the bottom? You can also try removing the application settings directory /Users/[username]/Library/Application Support/PyxelEdit
  • ToqueToque Posts: 20
    Ok.  Thanks for you suggestions.       I tried  disable asynchronous.    Does the same.    I will try and post a video.         

    Hmm  in finder and terminal I get "no directory exists".     But Im not very technically talented at all......   Is there a file I could search for and delete in the search function?

    I purchased Aseprite.     I like Pixel edit better.  
  • ToqueToque Posts: 20
    Ok. So I tried a few things and could not get it to work.   Restarted computer etc.  Very strange.      BUT   there was a larger  Catalina update so I went through that process this morning.      Now 10.15.2 (19C57).

    Just tried it and it does now indeed save!!!!!!  So happy.     If the problem happens again I will report.   

    thanks so much for you response.     I prefer pyxel Edit!!!!!!!  
  • DanikDanik Posts: 800
    I'm glad to hear you got it working! :)
  • ToqueToque Posts: 20
    Sorry it happened again today.  But not every time I save unlike before when I couldn't save at all.  I thought maybe a corrupted folder so tried a new folder.   I will try some experimenting.   

    It comes up with a save screen.    Click "save"   Then the same save screen comes up but its blank.  Click on save again but its frozen.   Have to force quit. 


  • ToqueToque Posts: 20
    edited January 11
    This save screen comes up and you can select, name and save.
    https://www.dropbox.com/s/wvgi7o2tgr0i87h/FIrstSaveScreen.png?dl=0

    But then immediately this screen comes up but its frozen.    Pyxel edit is frozen

    https://www.dropbox.com/s/uvk073ei3sssclg/ComesUpAfterSaveIsSelected.png?dl=0
    Not sure that helps.  
  • DanikDanik Posts: 800
    Strange. :/ Let me know if you figure out under what conditions it happens/doesn't happen so that I can attempt to reproduce it. Does it work randomly or only after restarting the program, or rebooting the computer?
  • ToqueToque Posts: 20
    https://youtu.be/oLTzYQgJLvo

    Sorry I've tried different things to try and isolate why its doing this.  Thought maybe a video might help at least explain it.     I tried changing names,  restarting.....  different folders.... new folders.........

    I can export my work but I lose my layers/  animations.     I will play with it a bit more but I might have to move on.    

    But thanks so much for looking at it and responding.  I do appreciate it.     I would delete and buy again if I knew that would work.    

    I do have to input my key every time and activate it.    But Ive had to do this for a long time so that hasn't changed.  

    Thanks again.  

      




  • DanikDanik Posts: 800
    The video says it's private so I couldn't watch it unfortunately.
    Yeah that doesn't sound like a sustainable way to work. Do you know if the autosaves work?
    I'll try to remember to post back in this thread if I manage to reproduce it and fix it.
  • ToqueToque Posts: 20
    edited February 5
    My apology.  I believe its a public video.    Not sure it will be of much use but you are welcome to have a look at it.   Its a short video. 

                   https://youtu.be/oLTzYQgJLvo             


    No I dont think the autosaves are working either.......
  • DanikDanik Posts: 800
    Thank you for the video. That is a bad issue indeed. Which specific version of Catalina are you running? I don't have the problem on 10.15.1, but I googled around and found some posts where people started having similar issues on 10.15.2.
    https://forums.macrumors.com/threads/macos-catalina-10-15-2-freezes-crashes-mba-every-single-day-am-i-alone.2216672/

    Maybe the first answer here is worth a shot:
    https://community.adobe.com/t5/photoshop/photoshop-2-2020-freezing-while-saving-on-mac-os-catalina/td-p/10776502?page=1

    I will try updating to the latest Catalina version soon to see if that triggers the problem.


  • Hmm I'm facing the same issue, I've tried changing the accessibility settings for PyxelEdit but no luck.. 
  • In terms of reproducible steps, I'm on MacOS Catalina 10.15.3 and I open PyxelEdit and start a new project, then save the project (this seems to work fine). If I then try and save the project again with a different file name the freeze occurs. The freeze also seems to occur if I open an existing project then try to re-save it with a different name. I'm really looking forward to a fix, I don't like Asesprite! Thanks for the awesome software by the way.
  • ToqueToque Posts: 20
    Yeah I tried again today.     10.15.3

    Tried multiple things.    Not able to save.     
    Well at least its not just me.    I wonder as other people update  they will soon have issues........

    The changing of preferences accessibility settings doesn't seem to work.  

    Thanks

  • DanikDanik Posts: 800
    I have updated to 10.15.3 and was able to reproduce the problem. I will try to find a solution as soon as I can.
  • LurkLurk Posts: 1
    I think I might have found something. When saving, I always switch to another folder before going back to the folder I want to save into(in my case, a desktop folder). It seems to nullify the freeze bug. I tried it with a few test files, some with no tiles, some with tiles.
  • ToqueToque Posts: 20
    Yes.   I tried a few times.       If you change the folder it does seem to save now.    But you have to change the folder.   If you save to the same folder it freezes.......

    Tried only   a few times so cant say I extensively tried different things.   
  • WygeWyge Posts: 1
    Hi to everyone!
    Catalina 10.15.3, same issue. Will try the method that Lurk describe, and give a feedback. And wait for bug fix, cause like Pyxel Edit!
  • JuanCollinJuanCollin Posts: 2
    Same issue here :neutral:

  • empikaempika Posts: 13
    Hey,

    Have the same issue on 10.15.4. Toque's workaround of switching folder first seems to work 👍
    The other area I've hit this issue is choosing a folder for the export output.

    Thanks!
  • ToqueToque Posts: 20
    Just lost some work and this is getting really old.    Yeah I used to just export everything before trying to save but that didnt seem to work for me now...........     Im   not sure why Im even using this anymore....   so frustrating

  • DanikDanik Posts: 800
    I can certainly understand your frustration. I haven't managed to find a solution yet, but I have narrowed it down a bit. I've got today off from work and I'm digging into it now, really hope to find a solution or workaround.
  • DanikDanik Posts: 800
    I have a build that maybe solves the problem. If anyone with the problem wants to help me test it just send me a message.
  • DanikDanik Posts: 800
    I have found that the error only seems to happen when the dialog has a file selected (highlighted with a gray background, see below) when you open it. If you browse away or create a new folder so that the selection goes away saving will work. This highlighted state will return each time you Save As until you create a new folder in the dialog, at which time it seems to get reset. Not sure what causes it to return though.
    I think the issue is in the AIR runtime's interaction with the operating system, so I don't think I can code around it. It seems to happen less frequently with the latest release of AIR, but I need to test more to see if it's solved completely. Let me know if you want to help out testing.

    Temporary workaround: Make sure there is no highlighted file before clicking Save!
    I also recommend lowering the autosave interval in the settings to minimize the risk of losing work.

  • DanikDanik Posts: 800
    The latest AIR runtime seems to fix the save dialog freeze issue, but it has at least one new issue where the license info isn't remembered between runs. Harman (who have taken over AIR development from Adobe) are aware of the issue, and they are actively developing AIR again so hopefully it will be fixed soon.
  • DanikDanik Posts: 800
    I just got a response from Harman letting me know they are looking at it.
    https://github.com/Gamua/Adobe-Runtime-Support/issues/205
  • ToqueToque Posts: 20
    edited May 15
    Sounds promising.  Thanks for the update.      I  like pyxel edit!!!!!   Im just used to it and like how it does animations.   Better than asp......  for me.      

    If I create a new folder every time I save it seems to work.   So I carry on.     

    I realize updates break these things......  Thanks for the effort.  
    ..........................................
    I just quit pyxel edit. (normally its always running)      Loaded it.    new project.    Save as.   Touched/ changed  nothing but it saved and it seems to be working.     Shut down and tried a few times and it doesn't lock up.    Its a strange thing.    

    Glad you can make sense of it.     Good luck!!

Sign In or Register to comment.