Pyxel crashes on copy or paste on mac

RisingDragoonRisingDragoon Posts: 2
edited July 2018 in Bug reports
70% of times that I use pyxel on mac, when I copy (cmd + C) or paste (cmd + V) it doesnt repond and It freeze for a long time
Pls fix it, couse I can't work with this bug

Thank you :smile: 

Edit (Danik): Please see this post for the cause and a workaround


  • ArjayArjay Posts: 2
    I'm having the same issue after "upgrading" to 10.13.1 High Sierra. I cannot copy & paste at all. Paste will crash the program. I've also submitted a bug report via Pyxel Edit. Thanks!
  • DanikDanik Posts: 870
    Hmm, sounds like an OS X update broke the copy paste. I only have an old Mac Mini that I haven't upgraded, but I will try to investigate.
    Does anyone else have this issue with High Sierra? Or anyone that runs High Sierra but doesn't have the issue?
  • ArjayArjay Posts: 2
    I shut down my mac and tried again. Wouldn't you know, everything seems to be working fine again. I have not gotten the crash or error again in Pyxel Edit, but I will upload any error logs if it happens again. Thanks!
  • Crash still in PyxelEdit 0.4.5... with High Sierra 10.13.1 on MacBook Pro 2017

  • i have same problem with copy and paste in Mac Os High Sierra 10.13.2, please i need a solution
  • I have the same problem since updating to 10.13.2. Reinstalling the application seems to help. 
  • I just updated to Mac OS High Sierra 10.13.3 on accident and now I can't copy and paste either. I reinstalled the application and it still didn't work.
  • DanikDanik Posts: 870
    Definitely sounds like a problem that has appeared in High Sierra then. Unfortunately I don't have a computer I can test with. Can I send someone with the problem some different test builds to try?
  • Danik. Just had same problem with High Sierra and copy paste. I would be happy to bug hunt for you.
  • Solved problem by looking at other comments; reinstalled.
  • Hi, just had this problem and found this thread. Tried reinstalling, but it didn't seem to do anything. Suggestions?
  • LunaiteLunaite Posts: 1
    Hi, I still have the same problem, and the only fix is deleting all PyxelEdit data in Application Support and restart it. But it is not a permanent fix. Any news?
  • DanikDanik Posts: 870
    I'm looking into the issue, but haven't found a definite cause or fix yet. Sounds like it's a bit random if reinstalling/deleting the settings fixes the issue. I don't have access to a Mac with High Sierra unfortunately.

    @fxdigitalworks @Dupl0mat ;@ivyheart @Darren ;@Magecoerlin ;@Lunaite does any of you want to try a test build that has a possible fix and some extra logging? If so send me a PM or email me!
  • CrashBamBoomCrashBamBoom Posts: 2
    edited May 2018
    (Seems to be fixed) 
    I am also having this same issue. Apple had a update today and I did it. I shouldn't of, because it worked yesterday, your version. Today after the update High Sierra 0.13.4 (17E202) the cut and paste doesn't work. I do get a pop box and I have sent in my ERROR report - I understand you don't have High Sierra, I can wait, but I can't work with your great software. It's really intuitive and I took to it the day I bought it. 
  • DanikDanik Posts: 870
    Now that I have a Mac to test on, I think I have isolated the problem.

    It seems that if one copies in Pyxel Edit after rebooting and without putting anything else on the pasteboard (text, images, ...) it fails. Simply copying anything else outside Pyxel Edit immediately fixes the issue until the next reboot. It appears to be a bug/incompatibility issue with Adobe AIR. It would be great if you that have the problem could try this workaround and let me know if it works or not!

    I have submitted a bug report with Adobe to have the issue fixed, please vote on it if you can so that it gets the attention of the developers:
  • ZachZach Posts: 1
    edited November 2019
    I'm having the same issue with macOS Catalina, the moment I hit enter after placing a copy nothing works. 

    Tried the "copy anything else" workaround with no luck.

    Update: After restarting it seems to be working fine.
Sign In or Register to comment.