Option "Reidentify layer tiles"

TheMnk Posts: 20
Hello, the option "Reidentify layer tiles ..." does not work, does nothing, the tiles still do not indicate a number and only have a dot in the upper left corner.
Only the tiles in the bottom row indicate a number but no more.

In the tilemap, each tile must have a number indicating which tile belongs in the tileset.


sky.png 1.7K

Comments

  • TheMnk Posts: 20
    edited April 20
    Only the bottom row has the numbers.


    sk6y.png 1.6K
  • CandyFaceCandyFace Posts: 479
    edited April 20
    The reason they don't have a number is because you haven't mapped the tiles. Use cmd + click(mac) or ctrl+click(windows) to add them to your tilemap. The tiles are not mapped by default.

    edit:
    eh my bad, there does seem to be a bug where if you zoom too far out, some of the mapping numbers will disappear. btw. make sure you're on the right layer, the numbers will only show if you're on the layer which has the mapping.
  • TheMnk Posts: 20
    I'm not sure I understand.

    I used "import tiled image".



    The tileset and tilemap are then created automatically.
    But the tilemap does not have the numbers, only the bottom row has them.
  • CandyFaceCandyFace Posts: 479
    Ah I see, yes something odd seems to happen when you use a width and height which are not identical.

    Usually you make tile dimensions in power of two to satisfy game engines. eg. 8x8, 16x16,32,32 etc... although any identical width and height should work as expected within PyxelEdit. Try to set your tile width and height to the same number, then the tiles should get mapped.
  • TheMnk Posts: 20
    Ok I understand.
    Then this "error" would have to be solved.
    I need the 16x8 measurements.
  • TheMnk Posts: 20
    Ok, now you can get the file for Tiled with all the tileset and tilemap data !.
    Although this error still exists with 16x8
Sign In or Register to comment.